Open Network Computing Remote Procedure Call

Open Network Computing (ONC) Remote Procedure Call (RPC) is a widely deployed remote procedure call system. ONC was originally developed by Sun Microsystems as part of their Network File System project, and is sometimes referred to as Sun ONC or Sun RPC. ONC is considered "lean and mean", but has limited appeal as a generalized RPC system for WANs or heterogeneous environments. Systems such as DCE, CORBA and SOAP are generally used in this wider role.

ONC is based on calling conventions used in Unix and the C programming language. It serializes data using the XDR, which has also found some use to encode and decode data in files that are to be accessed on more than one platform. ONC then delivers the XDR payload using either UDP or TCP. Access to RPC services on a machine are provided via a port mapper that listens for queries on a well-known port (number 111) over UDP and TCP.

Implementations of ONC RPC exist in most Unix-like systems. Microsoft supplies an implementation for Windows in their Microsoft Windows Services for UNIX product; in addition, a number of third-party implementation of ONC RPC for Windows exist, including versions for C/C++, Java, and .NET (see external links).

ONC RPC was described in RFC 1831, published in 1995. RFC 5531, published in 2009, is the current version. Authentication mechanisms used by ONC RPC are described in RFC 2695, RFC 2203, and RFC 2623.

In 2009, Sun relicensed the ONC RPC code under the standard 3-clause BSD license and then reconfirmed by Oracle Corporation in 2010 following confusion about the scope of the relicensing.

Famous quotes containing the words open, network, remote and/or call:

    “I am pretty sure that, if you will be quite honest, you will admit that a good rousing sneeze, one that tears open your collar and throws your hair into your eyes, is really one of life’s sensational pleasures.”
    —Robert Benchley (1889–1945)

    “Parents need all the help they can get. The strongest as well as the most fragile family requires a vital network of social supports.”
    —Bernice Weissbourd (20th century)

    “The places which I have described may seem strange and remote to my townsmen ... our account may have made no impression on your minds. But what is our account? In it there is no roar, no beach-birds, no tow-cloth.”
    —Henry David Thoreau (1817–1862)

    “I cannot call Riches better than the baggage of virtue. The Roman word is better, impedimenta. For as the baggage is to an army, so is riches to virtue. It cannot be spared nor left behind, but it hindereth the march; yea and the care of it sometimes loseth or disturbeth the victory.”
    —Francis Bacon (1561–1626)