IETF Language Tag - History

History

IETF language tags were first defined in RFC 1766, published in March 1995. The tags used ISO 639 two letter language codes, ISO 3166 two letter country codes, and allowed variant or script tags of three to eight letters.

In January 2001 this was superseded by RFC 3066, which added the use of ISO 639 part 2 three letter codes, permitted subtags with digits, and adopted the concept of language ranges from HTTP/1.1 to help with matching of language tags.

The next revision of the specification came in September 2006 with the publication of RFC 4646 (the main part of the specification) and RFC 4647 (which deals with matching behaviour). RFC 4646 introduced a more structured format for language tags, added the use of ISO 15924 four letter script codes and UN M.49 three digit geographical region codes, and replaced the old registry of tags with a new registry of subtags. The small number of previously defined tags that did not conform to the new structure were grandfathered in order to maintain compatibility with RFC 3066.

The current version of the specification, RFC 5646, was published in September 2009. The main purpose of this revision was to incorporate three letter codes from ISO 639 parts 3 and 5 into the Language Subtag Registry, in order to increase the interoperability between the ISO 639 and BCP 47 standards.

Read more about this topic:  IETF Language Tag

Famous quotes containing the word history:

    “In nature, all is useful, all is beautiful. It is therefore beautiful, because it is alive, moving, reproductive; it is therefore useful, because it is symmetrical and fair. Beauty will not come at the call of a legislature, nor will it repeat in England or America its history in Greece. It will come, as always, unannounced, and spring up between the feet of brave and earnest men.”
    —Ralph Waldo Emerson (1803–1882)

    “I am not a literary man.... I am a man of science, and I am interested in that branch of Anthropology which deals with the history of human speech.”
    —J.A.H. (James Augustus Henry)

    “If usually the “present age” is no very long time, still, at our pleasure, or in the service of some such unity of meaning as the history of civilization, or the study of geology, may suggest, we may conceive the present as extending over many centuries, or over a hundred thousand years.”
    —Josiah Royce (1855–1916)