John Curran (businessman) - Career

Career

Curran held positions as Chief Operating Officer & Chief Technical Officer of ServerVault (a federally-oriented secure hosting company acquired by Carpathia Hosting), Chief Technical Officer of XO Communications, and Chief Technical Officer of BBN. Curran also worked for Combustion Engineering/Asea Brown Boveri and Control Data Corporation. Curran provided technical leadership to BBN's commercial Internet efforts, including working on the early Internet research networks (CSNET and NEARNET) and the NSFNET Network Service Center (NNSC) coordination center for the pre-commercial Internet.

John Curran has served as Area Director for Operations and Network Management Area of the Internet Engineering Task Force (IETF), as member of the IP Next Generation (IPng) area which led IPv6 development, and co-chaired the IETF Uniform Resource Name working group. He has authored RFCs in early network joint operations (RFC 1355) and IPv6 area, as well as supporting work in network endpoint architecture. Curran has experience with Federal IT system security practices (including FISMA security standards) and cloud computing, and has advocated for improving of Federal IT access to cloud computing services.

Curran is author of RFC 5211, entitled "An Internet Transition Plan" which calls for moving the global Internet from its existing IPv4 protocol the newer IPv6 protocol, as well as RFC 1669 entitled "Market Viability as a IPng Criteria", which summarizes some of the challenges IPv6 will have competing against IPv4 and the inevitable arrival of network address translation devices. Curran is notable among association leaders for being quite reachable publicly, including directly responding to queries on public email lists.

Read more about this topic:  John Curran (businessman)

Famous quotes containing the word career:

    “The 19-year-old Diana ... decided to make her career that of wife. Today that can be a very, very iffy line of work.... And what sometimes happens to the women who pursue it is the best argument imaginable for teaching girls that they should always be able to take care of themselves.”
    —Anna Quindlen (b. 1952)

    “From a hasty glance through the various tests I figure it out that I would be classified in Group B, indicating “Low Average Ability,” reserved usually for those just learning to speak the English Language and preparing for a career of holding a spike while another man hits it.”
    —Robert Benchley (1889–1945)

    “A black boxer’s career is the perfect metaphor for the career of a black male. Every day is like being in the gym, sparring with impersonal opponents as one faces the rudeness and hostility that a black male must confront in the United States, where he is the object of both fear and fascination.”
    —Ishmael Reed (b. 1938)