Internet Layer - Relation To OSI Model

Relation To OSI Model

The internet layer of the TCP/IP model is often compared directly with the network layer (layer 3) in the Open Systems Interconnection (OSI) protocol stack. Although they have some overlap, these layering models represent different classification methods. In particular, the allowed characteristics of protocols (e.g., whether they are connection-oriented or connection-less) placed in these layers are different between the models. OSI's network layer is a "catch-all" layer for all protocols that facilitate network functionality. The internet layer, on the other hand, is specifically a suite of protocols that facilitate internetworking using the Internet Protocol.

Because of this, the OSI network layer is often described to include protocols such as the Address Resolution Protocol (ARP) which was placed in link layer by the original TCP/IP architects (RFC 1122, RFC 1123).

Strict comparison between the TCP/IP model and the OSI model should be avoided. Layering in TCP/IP is not a principal design criterion and is in general considered to be harmful (RFC 3439, section 3: "Layering Considered Harmful").

Despite clear primary references (see References below) and normative standards documents, the internet layer is still sometimes improperly called network layer, in analogy to the OSI model.

Read more about this topic:  Internet Layer

Famous quotes containing the words relation to, relation and/or model:

    “Light is meaningful only in relation to darkness, and truth presupposes error. It is these mingled opposites which people our life, which make it pungent, intoxicating. We only exist in terms of this conflict, in the zone where black and white clash.”
    —Louis Aragon (1897–1982)

    “There is undoubtedly something religious about it: everyone believes that they are special, that they are chosen, that they have a special relation with fate. Here is the test: you turn over card after card to see in which way that is true. If you can defy the odds, you may be saved. And when you are cleaned out, the last penny gone, you are enlightened at last, free perhaps, exhilarated like an ascetic by the falling away of the material world.”
    —Andrei Codrescu (b. 1947)

    “The best way to teach a child restraint and generosity is to be a model of those qualities yourself. If your child sees that you want a particular item but refrain from buying it, either because it isn’t practical or because you can’t afford it, he will begin to understand restraint. Likewise, if you donate books or clothing to charity, take him with you to distribute the items to teach him about generosity.”
    —Lawrence Balter (20th century)