Below is a list of FTP commands that may be sent to an FTP server, including all commands that are standardized in RFC 959 by the IETF. All commands below are RFC 959-based unless stated otherwise. Note that most command-line FTP clients present their own set of commands to users. For example, GET is the common user command to download a file instead of the raw command RETR.
| Command | RFC | Description |
|---|---|---|
| ABOR | &1000000 | Abort an active file transfer |
| ACCT | &1000000 | Account information |
| ADAT | &1002228RFC 2228 | Authentication/Security Data |
| ALLO | &1000000 | Allocate sufficient disk space to receive a file |
| APPE | &1000000 | Append. |
| AUTH | &1002228 RFC 2228 | Authentication/Security Mechanism |
| CCC | &1002228 RFC 2228 | Clear Command Channel |
| CDUP | &1000000 | Change to Parent Directory |
| CONF | &1002228 RFC 2228 | Confidentiality Protection Command |
| CWD | &1000697 RFC 697 | Change working directory |
| DELE | &1000000 | Delete file. |
| ENC | &1002228 RFC 2228 | Privacy Protected Channel |
| EPRT | &1002428 RFC 2428 | Specifies an extended address and port to which the server should connect |
| EPSV | &1002428 RFC 2428 | Enter extended passive mode |
| FEAT | &1002389 RFC 2389 | Get the feature list implemented by the server |
| HELP | &1000000 | Help |
| LANG | &1002640 RFC 2640 | Language Negotiation |
| LIST | &1000000 | Returns information of a file or directory if specified, else information of the current working directory is returned |
| LPRT | &1001639 RFC 1639 | Specifies a long address and port to which the server should connect |
| LPSV | &1001639 RFC 1639 | Enter long passive mode |
| MDTM | &1003659 RFC 3659 | Return the last-modified time of a specified file |
| MIC | &1002228 RFC 2228 | Integrity Protected Command |
| MKD | &1000000 | Make directory |
| MLSD | &1003659 RFC 3659 | Lists the contents of a directory if a directory is named |
| MLST | &1003659 RFC 3659 | Provides data about exactly the object named on its command line, and no others |
| MODE | &1000000 | Sets the transfer mode (Stream, Block, or Compressed) |
| NLST | &1000000 | Returns a list of file names in a specified directory |
| NOOP | &1000000 | No operation (dummy packet; used mostly on keepalives) |
| OPTS | &1002389 RFC 2389 | Select options for a feature |
| PASS | &1000000 | Authentication password |
| PASV | &1000000 | Enter passive mode |
| PBSZ | &1002228 RFC 2228 | Protection Buffer Size |
| PORT | &1000000 | Specifies an address and port to which the server should connect |
| PROT | &1002228 RFC 2228 | Data Channel Protection Level |
| PWD | &1000000 | Print working directory. Returns the current directory of the host |
| QUIT | &1000000 | Disconnect |
| REIN | &1000000 | Re initializes the connection |
| REST | &1003659 RFC 3659 | Restart transfer from the specified point |
| RETR | &1000000 | Transfer a copy of the file |
| RMD | &1000000 | Remove a directory |
| RNFR | &1000000 | Rename from. |
| RNTO | &1000000 | Rename to |
| SITE | &1000000 | Sends site specific commands to remote server |
| SIZE | &1003659 RFC 3659 | Return the size of a file |
| SMNT | &1000000 | Mount file structure |
| STAT | &1000000 | Returns the current status |
| STOR | &1000000 | Accept the data and to store the data as a file at the server site |
| STOU | &1000000 | Store file uniquely |
| STRU | &1000000 | Set file transfer structure |
| SYST | &1000000 | Return system type |
| TYPE | &1000000 | Sets the transfer mode (ASCII/Binary) |
| USER | &1000000 | Authentication username |
| XCUP | &1000775 RFC 775 | Change to the parent of the current working directory |
| XMKD | &1000775 RFC 775 | Make a directory |
| XPWD | &1000775 RFC 775 | Print the current working directory |
| XRCP | &1000743 RFC 743 | |
| XRMD | &1000775 RFC 775 | Remove the directory |
| XRSQ | &1000743 RFC 743 | |
| XSEM | &1000737 RFC 737 | Send, mail if cannot |
| XSEN | &1000737 RFC 737 | Send to terminal |
Read more about this topic: File Transfer Protocol
Famous quotes containing the words list of, list and/or commands:
“Loves boat has been shattered against the life of everyday. You and I are quits, and its useless to draw up a list of mutual hurts, sorrows, and pains.”
—Vladimir Mayakovsky (18931930)
“Loves boat has been shattered against the life of everyday. You and I are quits, and its useless to draw up a list of mutual hurts, sorrows, and pains.”
—Vladimir Mayakovsky (18931930)
“Unpaid work never commands respect ...”
—Harriot Stanton Blatch (18561940)