SIP requests are the codes used by Session Initiation Protocol for communication. To complement them there are SIP Responses, which generally indicate whether this request succeeded or failed, and in the latter case, why it failed.
| Request name | Description | Defined in |
|---|---|---|
| INVITE | Indicates a client is being invited to participate in a call session. | RFC 3261 |
| ACK | Confirms that the client has received a final response to an INVITE request. | RFC 3261 |
| BYE | Terminates a call and can be sent by either the caller or the callee. | RFC 3261 |
| CANCEL | Cancels any pending request. | RFC 3261 |
| OPTIONS | Queries the capabilities of servers. | RFC 3261 |
| REGISTER | Registers the address listed in the To header field with a SIP server. | RFC 3261 |
| PRACK | Provisional acknowledgement. | RFC 3262 |
| SUBSCRIBE | Subscribes for an Event of Notification from the Notifier. | RFC 3265 |
| NOTIFY | Notify the subscriber of a new Event. | RFC 3265 |
| PUBLISH | Publishes an event to the Server. | RFC 3903 |
| INFO | Sends mid-session information that does not modify the session state. | RFC 6086 |
| REFER | Asks recipient to issue SIP request (call transfer.) | RFC 3515 |
| MESSAGE | Transports instant messages using SIP. | RFC 3428 |
| UPDATE | Modifies the state of a session without changing the state of the dialog. | RFC 3311 |
Famous quotes containing the words list of, list, sip, request and/or methods:
“Do your children view themselves as successes or failures? Are they being encouraged to be inquisitive or passive? Are they afraid to challenge authority and to question assumptions? Do they feel comfortable adapting to change? Are they easily discouraged if they cannot arrive at a solution to a problem? The answers to those questions will give you a better appraisal of their education than any list of courses, grades, or test scores.”
—Lawrence Kutner (20th century)
“I made a list of things I have
to remember and a list
of things I want to forget,
but I see they are the same list.”
—Linda Pastan (b. 1932)
“The way you wear your hat
The way you sip your tea.”
—Ira Gershwin (18961983)
“Were all the worshippers of the gold calf to memorialize me and request a restoration of the deposits I would cut my right hand from my body before I would do such an act. The gold calf may be worshipped by others but as for myself I serve the Lord.”
—Andrew Jackson (17671845)
“With a generous endowment of motherhood provided by legislation, with all laws against voluntary motherhood and education in its methods repealed, with the feminist ideal of education accepted in home and school, and with all special barriers removed in every field of human activity, there is no reason why woman should not become almost a human thing. It will be time enough then to consider whether she has a soul.”
—Crystal Eastman (18811928)