Link Layer - Definition in Standards and Text Books

Definition in Standards and Text Books

LAN standards such as Ethernet and IEEE 802 specifications use terminology from the seven-layer OSI model rather than the TCP/IP reference model. The TCP/IP model in general does not consider physical specifications, rather it assumes a working network infrastructure that can deliver media level frames on the link. Therefore RFC 1122 and RFC 1123, the definition of the TCP/IP model, do not discuss hardware issues and physical data transmission and set no standards for those aspects, other than broadly including them as link-layer components. Some textbook authors have supported the interpretation that physical data transmission aspects are part of the link layer. That position will be held in the rest of this article. Others assumed that physical data transmission standards are not considered as communication protocols, and are not part of the TCP/IP model. These authors assume a hardware layer or physical layer below the link layer, and several of them adopt the OSI term data link layer instead of link layer in a modified description of layering. In the predecessor to the TCP/IP model, the Arpanet Reference Model (RFC 908, 1982), aspects of the link layer are referred to by several poorly defined terms, such as network-access layer, network-access protocol, as well as network layer, while the next higher layer is called internetwork layer. In some modern text books, network-interface layer, host-to-network layer and network-access layer occur as synonyms either to the link layer or the data link layer, often including the physical layer.

Read more about this topic:  Link Layer

Famous quotes containing the words definition, standards, text and/or books:

    “Scientific method is the way to truth, but it affords, even in
    principle, no unique definition of truth. Any so-called pragmatic
    definition of truth is doomed to failure equally.”
    —Willard Van Orman Quine (b. 1908)

    “That’s the great danger of sectarian opinions, they always accept the formulas of past events as useful for the measurement of future events and they never are, if you have high standards of accuracy.”
    —John Dos Passos (1896–1970)

    “What our eyes behold may well be the text of life but one’s meditations on the text and the disclosures of these meditations are no less a part of the structure of reality.”
    —Wallace Stevens (1879–1955)

    “Some time ago a publisher told me that there are four kinds of books that seldom, if ever, lose money in the United States—first, murder stories; secondly, novels in which the heroine is forcibly overcome by the hero; thirdly, volumes on spiritualism, occultism and other such claptrap, and fourthly, books on Lincoln.”
    —H.L. (Henry Lewis)