Relation To OSI Model
The internet layer of the TCP/IP model is often compared directly with the network layer (layer 3) in the Open Systems Interconnection (OSI) protocol stack. Although they have some overlap, these layering models represent different classification methods. In particular, the allowed characteristics of protocols (e.g., whether they are connection-oriented or connection-less) placed in these layers are different between the models. OSI's network layer is a "catch-all" layer for all protocols that facilitate network functionality. The internet layer, on the other hand, is specifically a suite of protocols that facilitate internetworking using the Internet Protocol.
Because of this, the OSI network layer is often described to include protocols such as the Address Resolution Protocol (ARP) which was placed in link layer by the original TCP/IP architects (RFC 1122, RFC 1123).
Strict comparison between the TCP/IP model and the OSI model should be avoided. Layering in TCP/IP is not a principal design criterion and is in general considered to be harmful (RFC 3439, section 3: "Layering Considered Harmful").
Despite clear primary references (see References below) and normative standards documents, the internet layer is still sometimes improperly called network layer, in analogy to the OSI model.
Read more about this topic: Internet Layer
Famous quotes containing the words relation to, relation and/or model:
“To be a good enough parent one must be able to feel secure in ones parenthood, and ones relation to ones child...The security of the parent about being a parent will eventually become the source of the childs feeling secure about himself.”
—Bruno Bettelheim (20th century)
“Unaware of the absurdity of it, we introduce our own petty household rules into the economy of the universe for which the life of generations, peoples, of entire planets, has no importance in relation to the general development.”
—Alexander Herzen (18121870)
“The Battle of Waterloo is a work of art with tension and drama with its unceasing change from hope to fear and back again, change which suddenly dissolves into a moment of extreme catastrophe, a model tragedy because the fate of Europe was determined within this individual fate.”
—Stefan Zweig (18811942)