Internet Key Exchange - History

History

IKE was originally defined in November 1998 by the Internet Engineering Task Force (IETF) in a series of publications (Request for Comments) known as RFC 2407, RFC 2408, and RFC 2409.

  • RFC 2407 defined The Internet IP Security Domain of Interpretation for ISAKMP.
  • RFC 2408 Internet Security Association and Key Management Protocol (ISAKMP)
  • RFC 2409 defined The Internet Key Exchange (IKE)

IKE was updated to version two (IKEv2) in December 2005 by RFC 4306. Some open details were clarified in October 2006 by RFC 4718. These two documents plus additional clarifications were combined into the updated IKEv2 RFC 5996 which was published in September 2010.

The parent organization of the IETF, The Internet Society (ISOC), has maintained the copyrights of these standards as being freely available to the Internet community.

Read more about this topic:  Internet Key Exchange

Famous quotes containing the word history:

    “The principle office of history I take to be this: to prevent virtuous actions from being forgotten, and that evil words and deeds should fear an infamous reputation with posterity.”
    —Tacitus (c. 55–117)

    “At present cats have more purchasing power and influence than the poor of this planet. Accidents of geography and colonial history should no longer determine who gets the fish.”
    —Derek Wall (b. 1965)

    “Whenever we read the obscene stories, the voluptuous debaucheries, the cruel and torturous executions, the unrelenting vindictiveness, with which more than half the Bible is filled, it would be more consistent that we called it the word of a demon than the Word of God. It is a history of wickedness that has served to corrupt and brutalize mankind.”
    —Thomas Paine (1737–1809)